Portal Disruption - (Mail Flow & Scanning are NOT affected)
Incident Report for Avanan
Resolved
This incident has been resolved.
Posted Mar 09, 2022 - 17:13 UTC
Monitoring
As we continue to wait on AWS confirmation, we see that service is back
Posted Mar 09, 2022 - 15:41 UTC
Identified
We identified an issue with our AWS services. At the moment, some Mail Explorer features may not be available.

AWS has acknowledged the problem and working on resolving the issue.
Posted Mar 09, 2022 - 13:57 UTC
This incident affected: Avanan Portal.