The incident has now been resolved by Microsoft. Please login to your Microsoft Status page for more information: https://status.office365.com/
Here is the summary of the issue as Microsoft has described:
User Impact: Users may have experienced delays or been unable to send or receive email messages within the Exchange Online service.
More info: Some users may have received the error message '451 4.3.2 Temporary server error. Please try again later ATTR1' if they attempted to email an impacted organization.
Final status: We've monitored the environment and confirmed that the queued emails have processed as expected.
Scope of impact: Impact was specific to organizations hosted from infrastructure located in North America. However, if a user not hosted on the affected infrastructure attempted to send an email to a user within an impacted organization, they may have been unable to send the email.
Start time: Thursday, April 22, 2021, 9:00 AM (1:00 PM UTC)
End time: Thursday, April 22, 2021, 12:30 PM (4:30 PM UTC)
Preliminary root cause: Microsoft preliminary investigation determined impact was caused by a load balancing configuration issue. This behavior occurred when a specific type of call happened when inbound mail was received. Under normal circumstances this type of call would be routed to the Data Center cache, but in this instance, the call was also being sent directly to the database, causing a conflict and resulting in a spike resource utilization.
Posted Apr 22, 2021 - 17:24 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2021 - 17:21 UTC
Investigating
We have received notification from Microsoft they are experiencing a service degradation which is impacting most Exchange Online users.
User impact: Users may be unable to send or receive email messages within the Exchange Online service.
If you are experiencing email delivery issues please login to your Microsoft Status page for more information: https://status.office365.com/
Posted Apr 22, 2021 - 15:33 UTC
This incident affected: Email Security - Inline Protection, Email Security - Detect and Prevent, and Email Security - Monitor Only.