Portal Disruption - (Mail Flow & Scanning are NOT affected)
Incident Report for Avanan
Resolved
This incident has been resolved.
Posted Mar 11, 2022 - 22:13 UTC
Identified
We identified an issue with our AWS services. At the moment, some Mail Explorer features may not be available for U.S. customers

AWS has acknowledged the problem and working on resolving the issue.
Posted Mar 11, 2022 - 19:08 UTC
This incident affected: Avanan Portal.